To view uptime history for your instance of Canvas, click here.

Canvas has been made aware of AWS connectivity issues in the APAC region. This could cause access problems for users and schools in that region.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 07, 2021 - 14:06 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 07, 2021 - 11:41 MST
This incident affected: Canvas (Canvas LMS).