To view uptime history for your instance of Canvas, click here.

Some users are experiencing 504 errors when accessing Canvas
Incident Report for Instructure
Resolved
The fix for this issue has been identified and has been communicated to those affected
Posted Jul 16, 2020 - 11:16 MDT
Monitoring
The performance from this incident should be back to operational. We will provide an update when we are in the all-clear.
Posted Jul 16, 2020 - 11:02 MDT
Investigating
We are currently investigating this issue and will provide updates as they come.
Posted Jul 16, 2020 - 10:47 MDT
This incident affected: Canvas (Canvas LMS).