To view uptime history for your instance of Canvas, click here.

Canvas test environment "Beta" is inaccessible
Incident Report for Instructure
Resolved
The beta environment is now functioning normally for all users. Please let us know if you run into any further trouble with your beta site.
Posted Jul 28, 2015 - 11:38 MDT
Monitoring
Our engineers have applied a fix to allow users to access the beta environment once again. We will continue monitoring the issue to ensure it is functioning correctly. We apologize for any inconvenience this is causing for any of your users.
Posted Jul 28, 2015 - 09:12 MDT
Investigating
Some users may not currently be able to access the Canvas test environment "Beta." Our engineers are currently looking into this issue. We apologize for the inconvenience.
Posted Jul 28, 2015 - 08:34 MDT