Parchment Digital Badges is currently allowing users to log in. We are monitoring the situation. Please reach out to support if you experience issues with your log in process.
Posted Apr 06, 2026 - 11:49 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 06, 2026 - 11:45 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 06, 2026 - 11:33 MDT
Investigating
We are currently investigating an issue with users attempting to long in on the US server. We are working diligently to get this resolved.
Posted Apr 06, 2026 - 09:47 MDT
This incident affected: Canvas (Canvas Credentials).