To view uptime history for your instance of Canvas, click here.

A subset amount of users are experiencing long load times or page errors when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 26, 2021 - 10:15 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2021 - 10:07 MDT
Investigating
We are currently investigating this issue.
Posted Mar 26, 2021 - 10:05 MDT
This incident affected: Canvas (Canvas).