To see historical uptime for Canvas and other services for a specific instance, click here.

Some users are seeing page errors when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 08, 2020 - 20:00 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2020 - 19:32 MDT
Update
We are continuing to work on a fix for this issue. Some impacted users are now able to access Canvas.
Posted Mar 08, 2020 - 19:17 MDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 08, 2020 - 18:56 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 08, 2020 - 18:39 MDT
Investigating
We are currently investigating this issue.
Posted Mar 08, 2020 - 18:21 MDT
This incident affected: Canvas (Canvas).