To view uptime history for your instance of Canvas, click here.

Mastery Connect Slowness and Page Errors
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Nov 04, 2022 - 12:48 MDT
Update
Newer Benchmark assessments are not presenting in searches or on the benchmark page. This is correcting as the fix is running
Posted Nov 04, 2022 - 10:05 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 04, 2022 - 09:08 MDT
Investigating
Users may be experiencing increased content load times and periodic page errors. Our developers are aware of the problem and are working towards a resolution.
Posted Nov 04, 2022 - 08:49 MDT
This incident affected: AWS Region (us-east-1) and Mastery (Mastery Connect, Item Bank).