To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
Canvas has resumed normal operational parameters, and we appreciate your patience while our team looked into this.
Posted Mar 19, 2020 - 14:36 MDT
Monitoring
Our Engineers were able to identify the cause and apply a fix, and it appears our Free for Teachers instances are loading normally. We'll continue to monitor this and provide an update shortly.
Posted Mar 19, 2020 - 14:21 MDT
Investigating
Some users are experiencing long load times when accessing Canvas when accessing our Free for Teacher site. We are looking into this issue and will provide updates as they come.
Posted Mar 19, 2020 - 14:14 MDT
This incident affected: Canvas (Canvas LMS).