To view uptime history for your instance of Canvas, click here.

Students unable to submit or resume certain assessments

Incident Report for Instructure

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2026 - 10:12 MDT

Investigating

Mastery Connect has identified that for a limited number of assessments, students may be unable to submit or resume a started assessment. We are still investigating the full scope but show no evidence that this is impacting Mastery Predictive Assessments.
Posted Aug 27, 2026 - 12:39 MDT
This incident affects: Mastery (Mastery Connect).