To view uptime history for your instance of Canvas, click here.

Some users in North America may be experiencing slow page load times
Incident Report for Instructure
Resolved
Our DevOps Team has Identified and resolved the slow page load times. We apologize for any inconvenience caused.
Posted Sep 04, 2018 - 08:00 MDT
Investigating
Canvas users in North America may be experiencing slow page load times when using Canvas. Our DevOps team is aware and investigating. We apologize for any inconvenience caused.
Posted Sep 04, 2018 - 07:49 MDT
This incident affected: Canvas (Canvas LMS).