To view uptime history for your instance of Canvas, click here.

A small amount of users are experiencing long load times when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 11, 2021 - 11:22 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 11, 2021 - 11:04 MST
Identified
Our team is aware that some users may be seeing long load times within Canvas and are actively working to correct this.
Posted Feb 11, 2021 - 10:59 MST
This incident affected: Canvas (Canvas).