To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times and page errors when accessing Canvas.

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Feb 23, 2023 - 13:53 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 23, 2023 - 13:50 MST

Identified

Our Engineering team is actively investigating and working to correct the long load times and page errors.
Posted Feb 23, 2023 - 13:24 MST
This incident affected: Instructure.