To view uptime history for your instance of Canvas, click here.

New Quizzes is experiencing slow load times for users

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Dec 06, 2024 - 13:22 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 06, 2024 - 12:55 MST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 06, 2024 - 10:09 MST

Investigating

We are currently investigating this issue.
Posted Dec 06, 2024 - 09:57 MST
This incident affected: AWS Region (us-east-1).