To view uptime history for your instance of Canvas, click here.

Assignments and quizzes showing error messages
Incident Report for Instructure
Resolved
The issue is now resolved; users are now able to access assignments and quizzes that were previously presenting an error message. We sincerely apologize for the trouble this issue caused students and teachers this morning. We will prepare an incident report and share it with admins at affected institutions by the end of the day tomorrow (Tuesday, 27 August, US Mountain Time).
Posted Aug 27, 2018 - 10:46 MDT
Update
We have identified the problem and are deploying a fix. The process of deploying the fix at this point during the day—with usage very high—is causing some users to see intermittent slow performance. This should clear up shortly as the deployment concludes. We will post another update in 15 minutes.
Posted Aug 27, 2018 - 10:29 MDT
Identified
Engineering believes an accidental change to some configuration variables may have caused this issue. They are working to restore the original values. We will provide another update in 15 minutes.
Posted Aug 27, 2018 - 10:14 MDT
Update
Update: the error appears:
- When a student tries to access an assignment or quiz
- When a teacher tries to edit an assignment or quiz

More information forthcoming shortly.
Posted Aug 27, 2018 - 10:04 MDT
Investigating
Users are seeing an error message that reads "no implicit conversion of nil into String" when accessing assignments and quizzes. Our engineers are working on a solution. We'll post an update in the next 15 minutes.
Posted Aug 27, 2018 - 10:02 MDT
This incident affected: Canvas (Canvas LMS).