To view uptime history for your instance of Canvas, click here.

Some Canvas users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 10, 2021 - 09:20 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 10, 2021 - 09:15 MST
Investigating
Some Canvas users are experiencing long load times or page time outs when accessing Canvas. Our DevOps team are currently investigating this issue, and we'll provide an update shortly.
Posted Feb 10, 2021 - 09:09 MST
This incident affected: Canvas (Canvas).