To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page errors when accessing Canvas
Incident Report for Instructure
Resolved
Load time have returned to normal.
Posted Jan 12, 2021 - 12:01 MST
Monitoring
Our team has added additional resources to help with the load times and page errors. We will continue to monitor this to ensure that service restores to normal.
Posted Jan 12, 2021 - 11:53 MST
This incident affected: Canvas (Canvas LMS).