To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 29, 2021 - 10:15 MDT
Investigating
We are currently investigating this issue.
Posted Mar 29, 2021 - 10:08 MDT
This incident affected: Canvas (Canvas).