Some Canvas users in the US experiencing slow load times
Incident Report for Canvas
Resolved
Our DevOps team identified the issue and Canvas has resumed normal service. Thank you for your patience and we apologize for any inconvenience.
Posted about 1 month ago. Apr 23, 2018 - 12:34 MDT
Update
Our DevOps team is continuing efforts to resolve the slow load times. Again, we apologize for any inconveniences this has caused.
Posted about 1 month ago. Apr 23, 2018 - 12:09 MDT
Update
Our DevOps team is continuing to work on a resolution for this issue. We apologize for any inconvenience this may cause your users.
Posted about 1 month ago. Apr 23, 2018 - 11:27 MDT
Identified
Our DevOps team has identified the cause of the slow load times. They are currently working to resolve this issue. Thank you for your patience.
Posted about 1 month ago. Apr 23, 2018 - 11:09 MDT
Investigating
We are aware of slow load times affecting a small portion of users in the US users. We apologize for the disruption to service and our Devops team are working on resolving the page load times.
Posted about 1 month ago. Apr 23, 2018 - 10:46 MDT