To view uptime history for your instance of Canvas, click here.

Some Canvas Clients are experiencing Errors
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 26, 2022 - 09:37 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2022 - 09:34 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 26, 2022 - 09:30 MDT
Investigating
Users are experiencing slow load times and errors when accessing Canvas in the US region.
Posted Sep 26, 2022 - 09:17 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).