To view uptime history for your instance of Canvas, click here.

Impact Dashboard, Messaging and Insights are unavailable.

Incident Report for Instructure

Postmortem

Date: Tuesday, November 18, 2025

Time of Initial Detection : 05:38 AM MST

Time of Resolution (Normal Operations): 09:02 AM MST

Duration of Impact: 3 hours and 24 minutes‌

1. Summary

A significant service degradation occurred due to an intermittent failure within the Cloudflare global network, our primary Domain Name System (DNS) provider. This issue affected the resolution of our domain names, leading to intermittent unavailability of several core services, most notably the Impact dashboard and Impact messaging/monitoring within the LMS.

2. Root Cause

The root cause was an issue external to our infrastructure involving the Cloudflare global network.

  • Preliminary Cause: Intermittent unavailability of the Cloudflare global network, impacting their application services and preventing reliable DNS resolution for our domain names.
  • Our Dependency: The incident was a direct result of our reliance on Cloudflare as our DNS provider.

3. Timeline of Events

‌Times in MST

05:38 AM - Investigating - Intermittent unavailability of the Impact dashboard and LMS messaging/monitoring was detected. Initial investigation confirmed an ongoing issue with the Cloudflare global network. Cloudflare had begun remediation efforts.

06:15 AM - Identified - Cloudflare announced they had identified the issue and were actively restoring their application services.

07:44 AM - Monitoring - Cloudflare confirmed the issue causing the service degradation was fixed. Our services began recovering, and internal teams started closely monitoring performance.

09:02 AM - Resolved - All systems operating normally. Performance monitoring confirmed full stability and the incident was officially closed.

4. Mitigation & Recovery

  1. Detection: The issue was initially detected through around 05:38 AM MST.
  2. External Monitoring: Continuous monitoring of the Cloudflare status page provided timely external confirmation and updates regarding the service restoration.
  3. Recovery: Full recovery was achieved externally by Cloudflare's resolution of their underlying network issue. Our services automatically or swiftly recovered once reliable DNS resolution was restored globally.‌

5. Conclusion

Recovery proceeded quickly once the underlying issue was resolved by the vendor.

Posted Nov 19, 2025 - 06:32 MST

Resolved

Cloudflare has been resolved, and all systems are currently operating normally. We are continuing to monitor performance closely to ensure full stability.
Posted Nov 18, 2025 - 08:32 MST

Monitoring

Cloudflare has fixed the issue which caused service degradation. Our services are recovering, and we are monitoring performance closely.
Posted Nov 18, 2025 - 07:44 MST

Identified

Cloudflare has identified the issue and is in the process of restoring their application services.
Posted Nov 18, 2025 - 06:15 MST

Investigating

The Impact dashboard is intermittently unavailable to ongoing issues with the Cloudflare global network. Impact messaging and monitoring within the LMS is also affected.
Cloudflare has begun remediation, and we are monitoring the situation closely.
We will continue to provide updates as more information becomes available.
Posted Nov 18, 2025 - 05:38 MST
This incident affected: Impact.