To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or slowness when accessing Canvas
Incident Report for Instructure
Resolved
Our Devops team was able to fix this issue quickly and Canvas is now fully functional.
Posted Nov 06, 2020 - 16:13 MST
Investigating
We are currently investigating this issue.
Posted Nov 06, 2020 - 16:10 MST
This incident affected: Canvas (Canvas LMS).