To view uptime history for your instance of Canvas, click here.

Slow Load Times
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Dec 03, 2020 - 12:40 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2020 - 12:29 MST
Investigating
Some users are experiencing slow load times in Canvas. Our engineers are investigating this.
Posted Dec 03, 2020 - 12:28 MST
This incident affected: Canvas (Canvas).