To view uptime history for your instance of Canvas, click here.

Some users are experiencing issues with some of MasteryConnect features.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 10, 2021 - 17:46 MST
Update
We are continuing to investigate this issue.
Posted Mar 10, 2021 - 17:34 MST
Investigating
We are currently investigating this issue.
Posted Mar 10, 2021 - 17:10 MST
This incident affected: Canvas (Canvas LMS).