To view uptime history for your instance of Canvas, click here.

504 and 502 Errors When Accessing Canvas
Incident Report for Instructure
Resolved
A fix has been pushed and it has resolved the issue. Thank you for your patience as we worked to resolve the issue.
Posted Jan 26, 2024 - 15:08 MST
Identified
The issue has been identified and a fix is currently being implemented.
Posted Jan 26, 2024 - 15:00 MST
Investigating
Some users are receiving 504 and 502 errors when attempting to access Canvas. Our engineering team is aware of the issue and are currently investigating.
Posted Jan 26, 2024 - 14:53 MST
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).