To view uptime history for your instance of Canvas, click here.

Some users are experiencing 504 errors in the US east region
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Dec 08, 2022 - 13:31 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 08, 2022 - 13:27 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 08, 2022 - 13:24 MST
Update
We are continuing to investigate this issue.
Posted Dec 08, 2022 - 13:17 MST
Update
We are continuing to investigate this issue.
Posted Dec 08, 2022 - 13:05 MST
Investigating
We are currently investigating this issue.
Posted Dec 08, 2022 - 13:05 MST
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).