To view uptime history for your instance of Canvas, click here.

Some users experiencing long load times when created objects.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 13:16 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2020 - 13:01 MDT
Update
Our Devops team is still investigating what is causing the 404 page errors when some users try to create objects in Canvas.
Posted Mar 17, 2020 - 12:43 MDT
Investigating
We are aware of an issue where some users are experiencing page errors when creating objects in Canvas such as Pages, Assignments, Sub-Accounts, etc.
Posted Mar 17, 2020 - 12:26 MDT
This incident affected: Canvas (Canvas LMS).