To view uptime history for your instance of Canvas, click here.

Some users are experiencing 504 errors when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved. We appreciate your patience and apologize for any and all inconveniences.
Posted May 01, 2020 - 19:07 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 01, 2020 - 19:02 MDT
Update
We are still actively working on a fix for this issue.
Posted May 01, 2020 - 19:00 MDT
Update
We are continuing to work on a fix for this issue.
Posted May 01, 2020 - 18:50 MDT
Update
We are continuing to work on a fix for this issue.
Posted May 01, 2020 - 18:39 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 01, 2020 - 18:13 MDT
Investigating
Some users are experiencing timeouts and page errors when attempting to access Canvas. We're currently investigating this issue, and will provide an update soon.
Posted May 01, 2020 - 18:09 MDT