To view uptime history for your instance of Canvas, click here.

Some users are seeing errors when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jun 14, 2020 - 21:00 MDT
Identified
Some users are seeing page errors while accessing Canvas. Our engineers are aware of this issue.
Posted Jun 14, 2020 - 20:44 MDT
This incident affected: Canvas (Canvas LMS).