To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page time outs when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 02, 2021 - 09:48 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 02, 2021 - 09:40 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 02, 2021 - 09:38 MST
Investigating
We are currently investigating this issue.
Posted Feb 02, 2021 - 09:37 MST
This incident affected: Canvas (Canvas LMS).