To view uptime history for your instance of Canvas, click here.

Some US based schools are running into longer than normal load times

Incident Report for Instructure

Resolved

The issue has been resolved, and users should be able to access Canvas as expected. Thank you so much for your patience.
Posted 6 years ago. Aug 27, 2019 - 09:41 MDT

Monitoring

Our DevOps team were able to identify the issue and implement a fix, and it appears that those pages are loading correctly now. We'll monitor this situation closely for the next few minutes.
Posted 6 years ago. Aug 27, 2019 - 09:34 MDT

Investigating

We are receiving reports that Canvas is experiencing longer than normal load times for some schools based in the US. Our DevOps team investigating this issue, and we'll provide an update on this shortly.
Posted 6 years ago. Aug 27, 2019 - 09:28 MDT
This incident affected: Canvas (Canvas LMS).