To view uptime history for your instance of Canvas, click here.

A small amount of users are experiencing long load times or page errors when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 01, 2021 - 23:48 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2021 - 23:45 MST
Investigating
We are currently investigating this issue.
Posted Mar 01, 2021 - 23:43 MST
This incident affected: Canvas (Canvas).