To view uptime history for your instance of Canvas, click here.

Slow Login Times For Some Users/Accounts
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jul 07, 2020 - 08:11 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2020 - 23:57 MDT
Update
We are continuing to investigate this issue.
Posted Jul 06, 2020 - 23:46 MDT
Update
We are continuing to investigate this issue.
Posted Jul 06, 2020 - 23:31 MDT
Update
We are continuing to investigate this issue.
Posted Jul 06, 2020 - 23:16 MDT
Investigating
Some users are experiencing slow loading times when attempting to login to Canvas. We are currently investigating the issue.
Posted Jul 06, 2020 - 23:13 MDT
This incident affected: Canvas (Canvas).