To view uptime history for your instance of Canvas, click here.

Some users in the Dublin AWS region are experiencing an error when previewing files in Canvas
Incident Report for Instructure
Resolved
Our Engineers have deployed a fix on the affected files, and those should now be previewing correctly. We apologize for the impact this had on you and your users.
Posted Sep 12, 2020 - 09:14 MDT
Update
New files are now processing correctly, and are properly generating previews again. We are still working to update affected files from the last 24 hours, which are not yet showing a preview. We'll provide an update once that is complete.
Posted Sep 11, 2020 - 12:02 MDT
Identified
Previewing of files in the Dublin region is still unavailable for some users. Our engineers are working to fix affected files for those users, and to get the DocViewer preview service working again.
Posted Sep 11, 2020 - 11:39 MDT
Investigating
Some users are getting an "{error: Invalid session}" error message when previewing files in Canvas. We are currently investigating this issue.
Posted Sep 11, 2020 - 05:20 MDT
This incident affected: Canvas (— Document previewing).