To view uptime history for your instance of Canvas, click here.

Users on Comcast Xfinity are seeing errors when trying to access Canvas
Incident Report for Instructure
Resolved
Our DevOps team is aware of the behavior and found that this is an issue with Comcast Xfinity, if you are still getting error messages please report this behavior to your Internet Service Provider.
Posted Mar 05, 2024 - 14:38 MST
Update
We are continuing to investigate this issue.
Posted Mar 05, 2024 - 14:34 MST
Update
We are continuing to investigate this issue.
Posted Mar 05, 2024 - 14:10 MST
Update
We are continuing to investigate this issue.
Posted Mar 05, 2024 - 13:56 MST
Investigating
We are currently investigating this issue.
Posted Mar 05, 2024 - 13:29 MST
This incident affected: Canvas (Canvas LMS).