To see historical uptime for Canvas and other services for a specific instance, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 24, 2020 - 08:07 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2020 - 07:57 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 24, 2020 - 07:47 MDT
Investigating
Some users are experiencing long load times when accessing Canvas. We are looking into this issue and will provide updates as they come.
Posted Mar 24, 2020 - 07:33 MDT
This incident affected: Canvas (Canvas).