To view uptime history for your instance of Canvas, click here.

Canvas logs, or Weblogs (including user agents), are currently not queryable. Any queries targeting Weblogs will result in Error 503.
Incident Report for Instructure
Resolved
The engineering team will continue to work on a fix while keeping the mentioned functionality disabled for the time of the investigation.
Posted Sep 29, 2023 - 09:56 MDT
Update
As an effort to prevent a wider incident and maintain Canvas Data 2 main functionality and uptime, the ability to query Weblogs (including user agents) was temporarily turned off for customers in North America (us-east-1 AWS Region, or IAD). The team is currently investigating the impact of queries targeting Weblogs on overall performance of CD2.
Posted Sep 29, 2023 - 05:16 MDT
Investigating
We are currently investigating this issue.
Posted Sep 29, 2023 - 02:58 MDT
This incident affected: AWS Region (us-east-1) and Canvas (Canvas Data 2).