To view uptime history for your instance of Canvas, click here.

A small subset of users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 07, 2020 - 10:03 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 07, 2020 - 09:49 MDT
Identified
We're still seeing longer load times for that subset of users, and our team is working on a solution. We'll provide an update shortly.
Posted Aug 07, 2020 - 09:41 MDT
Monitoring
Our DevOps team implemented a fix, and it appears that Canvas has resumed normal operations. We'll be monitoring the results for the next few minutes.
Posted Aug 07, 2020 - 09:32 MDT
Investigating
A small subset of users are experiencing long load times when accessing Canvas. Our DevOps team is currently investigating this issue, and we'll provide an update in a few minutes.
Posted Aug 07, 2020 - 09:26 MDT
This incident affected: Canvas (Canvas).