To view uptime history for your instance of Canvas, click here.

Some users are experiencing page errors with Studio
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jul 02, 2021 - 14:16 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2021 - 14:05 MDT
Investigating
We are currently investigating this issue.
Posted Jul 02, 2021 - 14:04 MDT
This incident affected: Canvas (— Media tools).