Canvas Support Phones System
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jun 30, 2020 - 14:13 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2020 - 14:01 MDT
Identified
The phone provider for Canvas Support is currently experiencing technical problems. Due to this fact reaching Canvas Support via phone may take longer than normal. You are still able to contact Canvas Support via our chat tool, email, and the help menu.
Posted Jun 30, 2020 - 13:48 MDT
This incident affected: Canvas (— Support: Phones/Chat).