Some users may receive errors or long load times when accessing Canvas

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Oct 29, 2022 - 20:13 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2022 - 20:06 MDT

Investigating

Users have reported errors and long loading times when attempting to access Canvas.
Posted Oct 29, 2022 - 19:26 MDT
This incident affected: AWS Region (eu-west-1).