To view uptime history for your instance of Canvas, click here.

Page Errors when Accessing Canvas Discussions Implementing Advanced Rubrics

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 18:03 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 10, 2026 - 17:50 MDT

Update

We are continuing to investigate this issue.
Posted Mar 10, 2026 - 17:50 MDT

Update

We are continuing to investigate this issue.
Posted Mar 10, 2026 - 17:49 MDT

Update

Some users may encounter page errors when accessing Canvas group discussions implementing advanced rubrics.
Posted Mar 10, 2026 - 17:18 MDT

Investigating

Some users may encounter page errors when accessing Canvas discussions.
Posted Mar 10, 2026 - 17:13 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1, ap-southeast-2).