To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
Load times have returned to normal.
Posted Oct 01, 2020 - 13:10 MDT
Monitoring
Our team was able to identify the cause of the load times impacting some users. Currently load times have returned to normal. We will continue to monitor the load times.
Posted Oct 01, 2020 - 13:00 MDT
Investigating
We have received reports that some users are experiencing slow load times when accessing Canvas. We are currently investigating the cause of these load times.
Posted Oct 01, 2020 - 12:55 MDT
This incident affected: Canvas (Canvas LMS).