To view uptime history for your instance of Canvas, click here.

users are running into error messages and slowness when using the Mastery Paths feature within Canvas
Incident Report for Instructure
Resolved
Load times have returned to normal and have held steady without further errors. Thank you for your patience while our team implemented the fix.
Posted Apr 20, 2020 - 09:59 MDT
Monitoring
Our team has implemented a fix and page loads have returned to normal. We will continue to monitor the fix to ensure that everything works as intended.
Posted Apr 20, 2020 - 09:46 MDT
Update
We are currently running an emergency maintenance to our Mastery Path feature within Canvas
Posted Apr 20, 2020 - 09:08 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 20, 2020 - 08:58 MDT
Investigating
We are currently investigating this issue.
Posted Apr 20, 2020 - 08:46 MDT
This incident affected: Canvas (Canvas LMS).