Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jan 27, 2020 - 20:13 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2020 - 20:13 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 27, 2020 - 20:12 MST
Investigating
Some users are experiencing long load times when accessing Canvas.
Posted Jan 27, 2020 - 20:08 MST