To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page time outs when accessing Canvas. This is happening in the EMEA region
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jan 07, 2021 - 08:11 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 07, 2021 - 08:05 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 07, 2021 - 08:03 MST
This incident affected: Canvas (Canvas).