To view uptime history for your instance of Canvas, click here.

Some users may be receiving a 500 error messages or general Canvas slowness when attempting to access Canvas if they are hosted in our IAD (North American) region.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 11:27 MDT
Investigating
We are currently investigating this issue.
Posted Oct 21, 2021 - 11:18 MDT
This incident affected: Canvas (Canvas LMS).