To view uptime history for your instance of Canvas, click here.

Some US based users experiencing page errors when accesses Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 06:33 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2021 - 06:29 MST
Investigating
We are currently investigating this issue.
Posted Jan 08, 2021 - 06:25 MST