To view uptime history for your instance of Canvas, click here.

Some users are having an issue accessing Canvas

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 12:45 MDT

Update

We are continuing to investigate this issue.
Posted Apr 14, 2025 - 12:39 MDT

Investigating

We are currently investigating this issue.
Posted Apr 14, 2025 - 12:39 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).