To see historical uptime for Canvas and other services for a specific instance, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
Canvas has resumed normal operational parameters, and we appreciate your patience while our team looked into this.
Posted Mar 19, 2020 - 12:57 MDT
Monitoring
We've identified and applied a fix, and Canvas appears to be loading normally. We'll be monitoring the situation and we'll provide another update shortly.
Posted Mar 19, 2020 - 12:42 MDT
Investigating
Some users are experiencing long load times when accessing Canvas. We are looking into this issue and will provide updates as they come.
Posted Mar 19, 2020 - 12:26 MDT
This incident affected: Canvas (Canvas).