To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved. Users should be able to access Canvas as expected.
Posted May 28, 2020 - 14:18 MDT
Monitoring
A fix has been implemented and we are currently monitoring the results.
Posted May 28, 2020 - 14:06 MDT
Investigating
We are aware of an issue where some users are experiencing long load times when accessing Canvas. We are currently investigating this issue.
Posted May 28, 2020 - 13:57 MDT
This incident affected: Canvas (Canvas LMS).